[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #10292(closed: fixed)

Opened 19 months ago

Last modified 14 months ago

Survey tool doesn't load

Reported by: 002-sl_0001@… Owned by: mark
Component: surveytool-other Data Locale: sl_SL
Phase: dsub Review: pedberg
Weeks: Data Xpath:
Xref:

Description

The Survey tool doesn't load. It was however working fine for the last two days. It crashed once in a while but it has always loaded after the "reload" button was clicked. Today, no section would load (or only some of them after a couple of tries of reloading/restarting). A printscreen of the issue is attached.

Attachments

Problem_w_SurveyTool.png (86.3 KB) - added by 002-sl_0001@… 19 months ago.
SurveyTool wouldn't load; prtscr of the issue.

Change History

Changed 19 months ago by 002-sl_0001@…

SurveyTool wouldn't load; prtscr of the issue.

comment:1 Changed 19 months ago by mark

  • Owner changed from anybody to emmons
  • Priority changed from assess to medium
  • Status changed from new to accepted
  • Milestone changed from UNSCH to 32

comment:2 Changed 19 months ago by srl

DataSection.java:1747

jo.put("extraAttributes", getNonDistinguishingAttributes());

this may be returning null here

it calls

return XPathParts.getFrozenInstance(path).getSpecialNondistinguishingAttributes();

comment:3 Changed 19 months ago by mark

  • Owner changed from emmons to mark

Thanks. I'll follow up on this from here.

comment:4 Changed 19 months ago by mark

Adding details from: ticket:10271

When I access http://st.unicode.org/cldr-apps/v#/da/C_SEEurope/ (Danish >
Currencies > Southern/Eastern Europe), I get an error message:

An error occurred while trying to 'process your request', and the error code is 'E_UNKNOWN'.

Details
http://st.unicode.org/cldr-apps/v#/da/C_SEEurope/
Could not fetch section - error SyntaxError / Unexpected token )

{"stro":false,"baseXpath":null,"pageId":"C_SEEurope","section":{"err":"Exception on writeSection:org.json.JSONException"}
url: /cldr-apps/RefreshRow.jsp?json=t&_=da&s=7F25436CE171EE5DD104B1A413AAE868&x=C_SEEurope&strid=&cacheKill=1494620342820

The problem occurs both in Firefox and Chrome.
The problem occurs both when I am logged in and when I access the tool anonymously.
The problem occurs on several currency pages but not all. E.g. North America loads without problems.
The problem does not occur when loading currencies for the same region for e.g. the de locale.

comment:5 Changed 19 months ago by mark

  • Status changed from accepted to reviewing
  • Review set to pedberg

comment:6 Changed 19 months ago by Christian Schmidt <c960657-unicode.org@…>

It seems to be working now (for Danish, at least).

comment:7 Changed 14 months ago by pedberg

  • Status changed from reviewing to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.