[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #10323(closed: duplicate)

Opened 18 months ago

Last modified 6 months ago

ST: Filipino forum does not load

Reported by: kristi Owned by: tbishop
Component: survey-backend Data Locale:
Phase: rc Review:
Weeks: Data Xpath:
Xref:

Description

Go to Forum Post for Filipino
Error: An error occurred while trying to 'process your request', and the error code is 'E_UNKNOWN'.

Reloading may resume your progress.

Attachments

filipino error.JPG (39.8 KB) - added by kristi 18 months ago.
filipino error-field view.JPG (29.3 KB) - added by kristi 17 months ago.

Change History

Changed 18 months ago by kristi

comment:1 Changed 18 months ago by mark

  • Status changed from new to accepted
  • Component changed from unknown to survey
  • Priority changed from assess to critical
  • Milestone changed from UNSCH to 32
  • Owner changed from anybody to srl
  • type changed from unknown to survey

comment:2 Changed 17 months ago by fredrik

http://st.unicode.org/cldr-apps/v#forum/fil//
undefined

The error message was:

SyntaxError: JSON Parse error: Unrecognized token '<'

comment:3 Changed 17 months ago by kristi

Also happening with Igbo forum: http://st.unicode.org/cldr-apps/v#forum/ig//

comment:4 Changed 17 months ago by kristi

  • Summary changed from ST: Filipino foum does not load to ST: Filipino forum does not load

Changed 17 months ago by kristi

comment:5 Changed 17 months ago by kristi

The same error now appears from the data point as well.
Repro: http://st.unicode.org/cldr-apps/v#/fil/T_Asia/31522f8a705fe95b
(Attached a picture of the error)

comment:6 Changed 17 months ago by srl

JSON error is because on fetch of http://st.unicode.org/cldr-apps/SurveyAjax?s=……SESSION………&what=forum_fetch&xpath=0&_=fil server gives

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error that prevented it from fulfilling this request.

exception

java.lang.NullPointerException
note The full stack trace of the root cause is available in the Apache Tomcat/8.0.30 logs.

Apache Tomcat/8.0.30

comment:7 Changed 14 months ago by srl

  • Owner changed from srl to frontend

comment:8 Changed 14 months ago by mark

  • Milestone changed from 32 to 33

Moving frontend bugs to next release

comment:9 Changed 12 months ago by kristi

  • Keywords Committed added

comment:10 Changed 12 months ago by mark

  • Phase changed from dsub to rc

comment:11 Changed 9 months ago by mark

  • Milestone changed from 33 to 34

comment:12 Changed 9 months ago by kristi

  • Keywords STP1 added; Committed removed

comment:13 Changed 7 months ago by tbishop

This ticket is referenced under Priorities for UI Improvement Goals at:

http://cldr.unicode.org/index/cldr-engineer/sow

TRAC keyword “STP1” -- High priority bugs.

comment:14 Changed 7 months ago by tbishop

Testing on localhost, I'm not able to reproduce the bug yet. On Firefox, Safari, Chrome (macOS), and Edge (Windows), I'm able to open the Forum and it looks OK: "Filipino Forum Posts", "Showing posts for Filipino and all sublocales.", "New Forum Post", "No posts in this forum."

On st.unicode.org I get "Please login before continuing" and I don't have an account yet.

comment:15 Changed 7 months ago by tbishop

  • Owner changed from frontend to tbishop

comment:16 Changed 6 months ago by tbishop

Errors (invalid json, null pointer) in some cases may result from queries on non-existent tables depending on FORUM_POSTS.isVersioned and FORUM_POSTS.hasBeta.

In other cases they are caused by sm.reg.getInfo(poster) returning null when poster id refers to a locked or deleted account. This is fixed in upcoming changes for 10935. Will display "[Poster no longer active]".

This ticket may be treated as a duplicate of https://unicode.org/cldr/trac/ticket/10935

Last edited 6 months ago by tbishop (previous) (diff)

comment:17 Changed 6 months ago by tbishop

  • Status changed from accepted to closed
  • Resolution set to duplicate
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.