[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #10329(closed survey: fixed)

Opened 6 months ago

Last modified 8 weeks ago

ST: Duration section throwing an error in some languages

Reported by: fredrik Owned by: mark
Component: survey Data Locale:
Phase: dsub Review: emmons
Weeks: Data Xpath:
Xref:

Description

Going to http://st.unicode.org/cldr-apps/v#/de/Duration/ in de, fr, nl (maybe others) throws an error:

An error occurred while trying to 'process your request', and the error code is 'E_UNKNOWN'.
Reloading may resume your progress.

Details
http://st.unicode.org/cldr-apps/v#/de/Duration/
Exception while loading: section - undefined is not an object (evaluating 'item.votes[topVoter].isVoteForBailey'), n=TypeError

Reload

Attachments

Change History

comment:1 Changed 6 months ago by mark

  • Owner changed from anybody to mark
  • Priority changed from assess to critical
  • Status changed from new to accepted
  • Milestone changed from UNSCH to 32

comment:2 Changed 6 months ago by srl

arg. browser ate my comments

The issue is line 3119 if(orgVoteValue !== undefined) here orgVoteValue is zero (for guest). also topVoter endsup being null so on line 3163 also of survey.js:

var baileyClass = (item.votes[topVoter].isVoteForBailey)?" fallback":"";

for the record, xpath= xpath "//ldml/units/unitLength[@type=\"short\"]/unit[@type=\"duration-day\"]/unitPattern[@count=\"one\"]"

vote resolver raw data: raw "{test: {randomTest }, lastRelease: {{0} Tg., approved}, bailey: “{0} d” trunk: {{0} Tg., approved}, {orgToVotes: apple={{0} Tg.=4}, guest={{0} d=0}, totals: {{0} Tg.=4, {0} d=0}, conflicted: []}, sameVotes: [], O: {0} Tg., N: {0} d, totals: {{0} Tg.=4, {0} d=0}, winning: {{0} Tg., approved}}"

Probably what is happening here is a split vote.

I thinkg a suggested solution is on line 3119 change to: if(orgVoteValue !== undefined && orgVoteValue>0) so we do not decorate if the org's vote ended up being a zero.

Last edited 6 months ago by srl (previous) (diff)

comment:3 Changed 6 months ago by srl

Why is {0} d getting zero votes (=0) here from the VoteResolver?

Last edited 6 months ago by srl (previous) (diff)

comment:4 Changed 6 months ago by srl

I will try to get http://cldr-smoke.unicode.org/smoketest/v#/de/Duration/7f0e0ebb5fd89f34 on smoketest to reproduce the error..

comment:5 Changed 6 months ago by srl

oh... it's zero valued because the guest user here is locked!

comment:6 Changed 6 months ago by srl

Alright! the problem was the locked user account resulted in a vote being present, but wih value of zero. I've now reproduced this on Smoketest.

comment:7 Changed 6 months ago by srl

  • Status changed from accepted to reviewing
  • Review set to emmons

comment:8 Changed 8 weeks ago by emmons

  • Status changed from reviewing to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.