[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #10537(closed tools: fixed)

Opened 12 months ago

Last modified 9 months ago

Emoji keyword cleanup for those repeats from Annotation names

Reported by: kristi Owned by: mark
Component: unknown Data Locale:
Phase: rc Review: pedberg
Weeks: Data Xpath:
Xref:

Description

From a CLDR side meeting at UTC:
Clean up keywords that are repeated from the names (We should have an automated process as BRS)

Attachments

Change History

comment:1 Changed 11 months ago by mark

  • Phase changed from dsub to rc
  • Priority changed from assess to major
  • Type changed from unknown to tools
  • Milestone changed from UNSCH to 32

comment:2 Changed 11 months ago by mark

  • Owner changed from anybody to mark
  • Status changed from new to accepted

comment:3 Changed 11 months ago by mark

I'd like to talk about this a bit more. Here's my concern. (Just modified this.)

Logically, the keywords contain the name as well. So let's take a scenario:


Version X:

  • Emoji1 has name=A, keywords=B|C|D but logically the keywords contain A also.

In data submission, people debate and decide that B is a better name for Emoji1. A is also a reasonable name, but they omit adding it to the keywords. So then the data looks like:

  • Emoji1 has name=B, keywords=B|C|D

In the BRS, we remove B from the keywords, and get

  • Emoji1 has name=B, keywords=C|D

Logically, the keywords "add in" the name for predictive typing. But in this process, we've lost a good alternative keyword for A.


I think the simplest way to avoid the problem is to actually add the names to the keywords in the BRS.

Then the process becomes:

In version X

  • Emoji1 has name=A, keywords=A|B|C|D

after data submission:

  • Emoji1 has name=B, keywords=A|B|C|D
Last edited 11 months ago by mark (previous) (diff)

comment:4 Changed 11 months ago by kristi

Makes sense.. This isn't a big deal, and it's for consistency and setting a common expectation.
So, touching up in the beginning to bring consistency/expectation upfront, then cleaning up any changes after makes sense.

comment:5 Changed 11 months ago by mark

Agreed to do as in comment:3

comment:6 Changed 10 months ago by mark

  • Status changed from accepted to reviewing
  • Review set to kristi

Added new tool and processed the files.

comment:7 Changed 10 months ago by kristi

  • Review changed from kristi to pedberg

Hi Peter,
I looked at some of the outcomes and they look fine, and also had Jeff review the code, but it'd be good to have you review code since you know better about the emoji structure.

comment:8 Changed 9 months ago by pedberg

  • Status changed from reviewing to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.