[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #10859(closed data: as-designed)

Opened 6 months ago

Last modified 6 weeks ago

Portuguese (pt_PT) doesn't have abbreviated forms for days name

Reported by: flodolo@… Owned by: fredrik
Component: datetime Data Locale: Portuguese (pt_PT)
Phase: dsub Review:
Weeks: Data Xpath:
Xref:

Description

Currently, pt_PT uses wide day names also for abbreviated forms, both standalone and formatting.

For example, "sun" (Sunday, abbreviated-formatting)
https://www.unicode.org/cldr/charts/32/by_type/date_&_time.gregorian.html#Days_-_abbreviated_-_Formatting

It's "dom" for pt, "Domingo" for pt_PT. For comparison, month names have abbreviated forms
https://www.unicode.org/cldr/charts/32/by_type/date_&_time.gregorian.html#360c210ad4f23085

This was original reported as a bug in the datetime picker component in Firefox
https://bugzilla.mozilla.org/show_bug.cgi?id=1418061

Attachments

Change History

comment:1 Changed 6 months ago by mark

Either delete or use the Mozilla names: "Seg", "Ter", "Qua", "Qui", "Sex", Sáb", "Dom".

comment:2 Changed 6 months ago by mark

  • Owner changed from anybody to fredrik
  • Priority changed from assess to major
  • Type changed from unknown to data
  • Status changed from new to accepted
  • Milestone changed from UNSCH to 33

comment:3 Changed 5 months ago by fredrik

Per our linguist:
The choice to use “segunda”, “terça”, “quarta”, etc., as the Abbreviated forms was a deliberate one as these are very common in software and “segunda” is much more recognisable than “seg”. Also note that these 3 letter abbreviations are already used in the Short format.

comment:4 Changed 5 months ago by fredrik

  • Status changed from accepted to closed
  • Resolution set to as-designed

comment:5 Changed 5 months ago by zbraniecki@…

The issue is really in ICU so reported it there as http://bugs.icu-project.org/trac/ticket/13592

comment:6 Changed 6 weeks ago by diogoconstantino@…

Being a native European Portuguese speaker I say your linguist is wrong, and it's obvious that on a calendar "segunda" isn't in any way more recognizable.

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.