[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #4013(closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Decide on process for updating <variable> in supplemental data

Reported by: mark Owned by: mark
Component: xxx-docs Data Locale:
Phase: Review: yoshito
Weeks: 0.01 Data Xpath:
Xref:

Description

Originally, <variable> was designed for verifying the attribute values in the actual CLDR data were what we wanted, eg ...type="US" vs type="666"

The question is, what do we want to do when codes become obsolete? Do we want to remove them from both the data and from the corresponding <variable>? After some time period?

Attachments

Change History

comment:1 Changed 4 years ago by mark

Some thoughts about having a 5 year rule for deprecation...

comment:2 Changed 4 years ago by mark

  • Cc yoshito added
  • Priority changed from assess to major
  • Component changed from unknown to design
  • Milestone changed from UNSCH to 21m2

comment:3 Changed 4 years ago by mark

  • Milestone 21m2 deleted

comment:4 Changed 4 years ago by mark

  • Milestone set to postpone

comment:5 Changed 4 years ago by mark

  • Owner changed from somebody to mark
  • Status changed from new to assigned
  • Summary changed from Decide on process for updating <variable> in supplemental data to Decide on process for updating <variable> in supplemental data, modify tools as necessary
  • Component changed from design to tools
  • Milestone changed from postpone to 21

Agreed on policy

  1. Focus on use in validating main.
  2. Used for bulk upload checking, and final release checking.
  3. For language codes, includes all and only those that we add intentionally (not all language codes). Remove any that we don’t want in main (that is, private use).
  4. For all codes, generally use a 5 year rule for obsoleting (removing from variable). Currency translations stay around longer.
  5. But discuss in CLDR group any that are being removed.

comment:6 Changed 4 years ago by mark

  • Keywords google added

comment:7 Changed 4 years ago by mark

  • Weeks set to 0.01
  • Component changed from tools to docs

comment:8 Changed 4 years ago by mark

  • Summary changed from Decide on process for updating <variable> in supplemental data, modify tools as necessary to Decide on process for updating <variable> in supplemental data

comment:9 Changed 4 years ago by mark

  • Review set to yoshito
  • Milestone changed from 21 to 22m1

Added the following:

The variable values are intended for internal testing, and do not necessarily include all valid elements. For example, for primary language codes, they include the subset that occur in CLDR locale data. They are intended for a particular version of CLDR, and may omit deprecated codes that were present in earlier versions.

comment:10 Changed 3 years ago by mark

  • Milestone changed from 22m1 to 21

comment:11 Changed 3 years ago by yoshito

  • Status changed from assigned to closed
  • Resolution set to fixed

r6512 restored the segment accidentally lost by the previous change. Closing.

View

Add a comment

Modify Ticket

Action
as closed
The ticket will be disowned. The resolution will be deleted. Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.