[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #4764(closed enhancement: fixed)

Opened 6 years ago

Last modified 3 years ago

Add numeric currency code mappings

Reported by: mark Owned by: ccornelius
Component: supplemental Data Locale:
Phase: rc Review: emmons
Weeks: Data Xpath:
Xref:

Description

We'd like to add data for mapping numeric currency codes (right now there is data in .txt files in CLDR).

We have:

    <codeMappings>
        <territoryCodes type="AA" numeric="958" alpha3="AAA"/>
        <territoryCodes type="AC" alpha3="ASC"/>
        <territoryCodes type="AD" numeric="020" alpha3="AND" fips10="AN"/>

The corresponding format would be:

    <codeMappings>
        ...
        <currencyCodes type="EUR" numeric="978"/>
        <currencyCodes type="SUR" numeric="643"/>
        <currencyCodes type="RUB" numeric="643"/>

We would update http://cldr.unicode.org/development/updating-codes/update-currency-codes so that it generates the numerics from the ISO site.

(We need to dig into the data to see if there are any cases where an alpha code has two numerics.)

Attachments

iso4217.xml (12.8 KB) - added by ccornelius@… 5 years ago.
All ISO 4217 alpha3 and numeric codes. Note that some numeric codes have been reused in ISO4217.

Change History

comment:1 Changed 6 years ago by mark

  • Type changed from unknown to enhancement
  • Component changed from unknown to data

comment:2 Changed 6 years ago by markus

I submitted IcuBug:9331 for using this data in ICU API.

comment:3 Changed 6 years ago by mark

  • Owner changed from anybody to markus
  • Priority changed from assess to major
  • Status changed from new to assigned
  • Milestone changed from UNSCH to 22

Look at what Yoshito has done in ICU.

comment:4 Changed 6 years ago by mark

  • Cc yoshito added

comment:5 Changed 6 years ago by yoshito

ICU imports currency numeric/alpha code mappings directly from the XML files maintained by the ISO 4217 maintenance body (http://www.currency-iso.org/).
We once discussed if we should import the data to CLDR, but we agreed NOT to do so in the CLDR TC call on 2011-12-07. See IcuBug:8991 for the details. But, I personally think it's OK to move the data to CLDR if necessary. Probably need to discuss about this in the CLDR TC again.

comment:6 Changed 6 years ago by mark

Move the data into a separate file

Changed 5 years ago by ccornelius@…

All ISO 4217 alpha3 and numeric codes. Note that some numeric codes have been reused in ISO4217.

comment:7 Changed 5 years ago by markus

  • Milestone changed from 22 to 23dsub

comment:8 Changed 5 years ago by emmons

  • Milestone changed from 23dsub to 23dres

comment:9 Changed 5 years ago by markus

  • Owner changed from markus to ccornelius

comment:10 Changed 5 years ago by emmons

  • Milestone changed from 23dres to 24dsub

Moving all Steven's 23dres to 24dsub

comment:11 Changed 5 years ago by emmons

  • Milestone changed from 24dsub to 24dres

comment:12 Changed 4 years ago by ccornelius

Confirmed that the numeric-alpha mapping is 1-to-1. There are 182 pairs.
I'll be adding these to common/supplemental/supplementalData.xml.

comment:13 Changed 4 years ago by emmons

  • Milestone changed from 24rc to 25design

comment:14 Changed 4 years ago by emmons

  • Milestone changed from 25design to 25rc

Moving all 25dsub and 25design tickets to 25rc. If you plan to complete items in the 25M1 time frame, please move those tickets to 25M1.

comment:15 Changed 4 years ago by ccornelius@…

I hope to address this soon, but am not sure how to move to 25M1.

comment:16 Changed 4 years ago by ccornelius

  • Milestone changed from 25rc to 25M1

Moved go 25M1. Now working to add to cldr/common/supplemental/supplementalData.xml.

comment:17 Changed 4 years ago by mark

  • Milestone changed from 25M1 to 25rc

comment:18 Changed 4 years ago by mark

  • Milestone changed from 25rc to 25final

comment:19 Changed 4 years ago by emmons

  • Component changed from data to data-supplemental

comment:20 Changed 4 years ago by mark

  • Milestone changed from 25final to 26dsub

no work done on this, so pushing.

comment:21 Changed 4 years ago by emmons

  • Milestone changed from 26dsub to 26dvet

Moving all 26dsub to 26dvet. Please assess the need to complete tickets by 26dvet, which is 2014-06-19

comment:22 follow-up: ↓ 25 Changed 3 years ago by ccornelius

  • Status changed from assigned to reviewing
  • Review set to emmons

svn commit -m "cldrbug 4764: Add numeric currency code mappings"
svn status -u
Status against revision: 10822

Note that the page http://cldr.unicode.org/development/updating-codes/update-currency-codes still needs be updated with instructions on generating the new currencyCodes for supplementalData.xml.

comment:23 Changed 3 years ago by emmons

  • Status changed from reviewing to accepted

I don't understand... There are no commits against this ticket. And if the instructions still need to be updated then this ticket isn't ready for review.

comment:24 Changed 3 years ago by emmons

  • Milestone changed from 26dvet to 26rc

comment:25 in reply to: ↑ 22 Changed 3 years ago by srl

Replying to ccornelius:

svn commit -m "cldrbug 4764: Add numeric currency code mappings"
svn status -u
Status against revision: 10822

Note that the page http://cldr.unicode.org/development/updating-codes/update-currency-codes still needs be updated with instructions on generating the new currencyCodes for supplementalData.xml.

Were there any other errors? Same problem as http://unicode.org/cldr/trac/ticket/6977#comment:4 ?

comment:26 Changed 3 years ago by markus

  • Status changed from accepted to reviewing

comment:27 Changed 3 years ago by nrunge@…

It seems CLDR 26 won't include the historic ISO 4217 codes, from table A.3. Was there a particular reason? Issues with reused numeric codes?

comment:28 Changed 3 years ago by markus

  • Phase set to rc
  • Milestone changed from 26rc to 26

comment:29 Changed 3 years ago by pedberg

OK, the tools/java/org/unicode/cldr/icu/ldml2icu_supplemental.txt changes for this are not suitable. They just add 2-element entries for currency-code mappings to the existing codeMappings resource in supplementalData.txt, which is currently assumed by ICU code to have only territory mappings, all of whose entries are 3 elements.

I think we need to put the new currency code mappings in a separate resource codeMappingsCurrency which will only have 2-element entries.

Fixed.

Last edited 3 years ago by pedberg (previous) (diff)

comment:30 Changed 3 years ago by pedberg

http://bugs.icu-project.org/trac/ticket/11224 is about what to do with this in ICU, since we already had such a table (and a larger one too).

comment:31 Changed 3 years ago by emmons

  • Status changed from reviewing to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.