[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search

CLDR Ticket #5272(closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Add structure for as-large-or-larger

Reported by: mark Owned by: jchye
Component: main Data Locale:
Phase: Review: mark
Weeks: Data Xpath:


In English, you can express a range of numbers with a lowest element using the following syntax:


This means {x : x ≥ 99}.

In other languages, this may vary. In particular, in some countries a plus or minus sign + is written on the right side of the number. Thus 99+ or 99- would be how one writes +99 or -99.

By having a pattern for this, we can allow for alternate representations (eg "≥{0}") or for the insertion of BIDI controls. The value may vary according to number systems.

Possible structure:

<asBigAsPattern numberSystem="latn">≥{0}</asBigAsPattern>

(Don't like the name. Suggestions?)


Change History

comment:1 Changed 6 years ago by mark

  • Status changed from new to assigned
  • Component changed from unknown to design
  • Priority changed from assess to major
  • Milestone changed from UNSCH to 23
  • Owner changed from anybody to jchye
  • Type changed from unknown to defect

comment:2 Changed 6 years ago by srl

First, I think it should be a type, not an element.
...<miscPatterns>... <pattern type="asBigAs">{0}+</pattern></miscPatterns>

as far as the name- some ideas - could be an overflow ( / underflow ), over range, under range

comment:3 Changed 5 years ago by jchye

  • Milestone changed from 23 to 24dsub

comment:4 Changed 5 years ago by mark

Agree with Steven's comment, making it a type.

comment:5 Changed 5 years ago by jchye

  • Component changed from design to data

Adding ldml/numbers/miscPatterns[@numberSystem="latn"]/pattern[@type="atLeast"]
(the complementary attribute would be "atMost")

comment:6 Changed 5 years ago by jchye

  • Review set to mark

comment:7 Changed 5 years ago by kent.karlsson14@…

I think one should use "⩾{0}" (and "⩽{0}" for the atMost) in root rather than "{0}+", which, however popular, is a bit idiosyncratic and not at all a good default.

comment:8 Changed 5 years ago by mark

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:9 Changed 4 years ago by emmons

  • Milestone 24dsub deleted

Milestone 24dsub deleted


Add a comment

Modify Ticket

as closed
Next status will be 'new'
Next status will be 'closed'

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.