[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #5275(closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Time zone display name data problems in CLDR 22 release candidate

Reported by: yoshito Owned by: yoshito
Component: timezone Data Locale:
Phase: Review: emmons
Weeks: Data Xpath:
Xref:

Description

While testing ICU, I found two problems in CLDR 22 time zone display name data. With time zone format full roundtrip test with ICU4J trunk, following problems were reported.

1) en_LR

     [java]     Locale: en_LR 
     [java]         pattern: z 
     [java]         pattern: zzzz 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/Dublin, locale=en_LR, pattern=zzzz, text=1971-10-31T02:00:00.000 Greenwich Mean Time, gmt=1971-10-31T02:00:00.000, time=57722400000, restime=57725070000, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/Dublin, locale=en_LR, pattern=zzzz, text=1972-03-19T01:59:59.999 Greenwich Mean Time, gmt=1972-03-19T01:59:59.999, time=69818399999, restime=69821069999, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/Guernsey, locale=en_LR, pattern=zzzz, text=1971-10-31T02:00:00.000 Greenwich Mean Time, gmt=1971-10-31T02:00:00.000, time=57722400000, restime=57725070000, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/Guernsey, locale=en_LR, pattern=zzzz, text=1972-03-19T01:59:59.999 Greenwich Mean Time, gmt=1972-03-19T01:59:59.999, time=69818399999, restime=69821069999, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/Isle_of_Man, locale=en_LR, pattern=zzzz, text=1971-10-31T02:00:00.000 Greenwich Mean Time, gmt=1971-10-31T02:00:00.000, time=57722400000, restime=57725070000, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/Isle_of_Man, locale=en_LR, pattern=zzzz, text=1972-03-19T01:59:59.999 Greenwich Mean Time, gmt=1972-03-19T01:59:59.999, time=69818399999, restime=69821069999, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/Jersey, locale=en_LR, pattern=zzzz, text=1971-10-31T02:00:00.000 Greenwich Mean Time, gmt=1971-10-31T02:00:00.000, time=57722400000, restime=57725070000, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/Jersey, locale=en_LR, pattern=zzzz, text=1972-03-19T01:59:59.999 Greenwich Mean Time, gmt=1972-03-19T01:59:59.999, time=69818399999, restime=69821069999, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/London, locale=en_LR, pattern=zzzz, text=1971-10-31T02:00:00.000 Greenwich Mean Time, gmt=1971-10-31T02:00:00.000, time=57722400000, restime=57725070000, diff=2670000 
     [java]     Error: FAIL: Time round trip failed for tzid=Europe/London, locale=en_LR, pattern=zzzz, text=1972-03-19T01:59:59.999 Greenwich Mean Time, gmt=1972-03-19T01:59:59.999, time=69818399999, restime=69821069999, diff=2670000 
     [java]         pattern: Z 
     [java]         pattern: ZZZZ 
     [java]         pattern: ZZZZZ 
     [java]         pattern: v 
     [java]         pattern: vvvv 
     [java]         pattern: V 
     [java]         pattern: VVVV 

This issue is caused by a bad golden zone mapping. To fix this, delete the line for "LR" below in metaZones.xml

<mapZone other="GMT" territory="001" type="Atlantic/Reykjavik"/> 
<mapZone other="GMT" territory="BF" type="Africa/Ouagadougou"/> 
<mapZone other="GMT" territory="CI" type="Africa/Abidjan"/> 
<mapZone other="GMT" territory="GB" type="Europe/London"/> 
<mapZone other="GMT" territory="GH" type="Africa/Accra"/> 
<mapZone other="GMT" territory="GM" type="Africa/Banjul"/> 
<mapZone other="GMT" territory="GN" type="Africa/Conakry"/> 
<mapZone other="GMT" territory="IE" type="Europe/Dublin"/> 
<mapZone other="GMT" territory="LR" type="Africa/Monrovia"/> <!-- Monrovia does not satisfy the criteria of 'golden zone' -->
<mapZone other="GMT" territory="ML" type="Africa/Bamako"/> 
<mapZone other="GMT" territory="MR" type="Africa/Nouakchott"/> 
<mapZone other="GMT" territory="SH" type="Atlantic/St_Helena"/> 
<mapZone other="GMT" territory="SL" type="Africa/Freetown"/> 
<mapZone other="GMT" territory="SN" type="Africa/Dakar"/> 
<mapZone other="GMT" territory="ST" type="Africa/Sao_Tome"/> 
<mapZone other="GMT" territory="TG" type="Africa/Lome"/>

2) ko_KP

     [java]     Locale: ko_KP 
     [java]         pattern: z 
     [java]         pattern: zzzz 
     [java]         pattern: Z 
     [java]         pattern: ZZZZ 
     [java]         pattern: ZZZZZ 
     [java]         pattern: v 
     [java]         pattern: vvvv 
     [java]     Error: FAIL: Time round trip failed for tzid=Asia/Seoul, locale=ko_KP, pattern=vvvv, text=1960-05-15T01:00:00.000 \uB300\uD55C\uBBFC\uAD6D \uC2DC\uAC04, gmt=1960-05-14T16:00:00.000, time=-303984000000, restime=-303980400000, diff=3600000 
     [java]     Error: FAIL: Time round trip failed for tzid=Asia/Seoul, locale=ko_KP, pattern=vvvv, text=1960-09-12T22:59:59.999 \uB300\uD55C\uBBFC\uAD6D \uC2DC\uAC04, gmt=1960-09-12T13:59:59.999, time=-293536800001, restime=-293533200001, diff=3600000 
     [java]     Error: FAIL: Time round trip failed for tzid=Asia/Seoul, locale=ko_KP, pattern=vvvv, text=1961-08-10T00:30:00.000 \uB300\uD55C\uBBFC\uAD6D \uC2DC\uAC04, gmt=1961-08-09T16:00:00.000, time=-264931200000, restime=-264929400000, diff=1800000 
     [java]     Error: FAIL: Time round trip failed for tzid=Asia/Seoul, locale=ko_KP, pattern=vvvv, text=1968-09-30T23:59:59.999 \uB300\uD55C\uBBFC\uAD6D \uC2DC\uAC04, gmt=1968-09-30T15:29:59.999, time=-39515400001, restime=-39517200001, diff=-1800000 
     [java]         pattern: V 
     [java]         pattern: VVVV 

This problem is caused by generic name of meta zone Korea - duplicated with generic location fallback name "{0} Time". After some investigation, I found the meta zone display names are not appropriate for North Korea.

ko.xml

        <metazone type="Korea"> 
                <long> 
                        <generic>대한민국 시간</generic> 
                        <standard>대한민국 표준시</standard> 
                        <daylight>대한민국 하계 표준시</daylight> 
                </long> 
        </metazone>

I think we need following data in ko_KP.xml

        <metazone type="Korea"> 
                <long> 
                        <generic>조선 시간</generic> 
                        <standard>조선 표준시</standard> 
                        <daylight>조선 하계 표준시</daylight> 
                </long> 
        </metazone>

Attachments

Change History

comment:1 Changed 5 years ago by yoshito

  • Owner changed from emmons to yoshito
  • Status changed from new to assigned

comment:2 Changed 5 years ago by yoshito

  • Status changed from assigned to accepted
  • Review set to emmons

comment:3 Changed 5 years ago by emmons

  • Status changed from accepted to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.