[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #6311(closed unknown: fixed)

Opened 5 years ago

Last modified 4 years ago

CLDRFile.getName exception

Reported by: srl Owned by: mark
Component: unknown Data Locale:
Phase: Review: srl
Weeks: Data Xpath:
Xref:

Description

sorry, I don't have any more context here. perhaps getName could catch/rethrow and print an err message at least, or be more robust with a warningn.

Caused by: java.util.NoSuchElementException
        at java.util.StringTokenizer.nextToken(StringTokenizer.java:349)
        at org.unicode.cldr.util.LanguageTagParser.getSubtag(LanguageTagParser.java:354)
        at org.unicode.cldr.util.LanguageTagParser.set(LanguageTagParser.java:182)
        at org.unicode.cldr.util.CLDRFile.getName(CLDRFile.java:2156)
        at org.unicode.cldr.util.CLDRFile.getName(CLDRFile.java:2256)
        at org.unicode.cldr.util.CLDRLocale$CLDRFormatter.getDisplayName(CLDRLocale.java:153)
        at org.unicode.cldr.util.CLDRLocale.getDisplayName(CLDRLocale.java:503)
        at org.unicode.cldr.util.CLDRLocale.getDisplayName(CLDRLocale.java:487)
        at org.apache.jsp.WEB_002dINF.tmpl.ajax_005fstatus_jsp._jspService(ajax_005fstatus_jsp.java:98)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
        at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:433)
        ... 35 more

Attachments

Change History

comment:1 Changed 5 years ago by mark

  • Owner changed from anybody to mark
  • Priority changed from assess to critical
  • Status changed from new to assigned
  • Milestone changed from UNSCH to 24dvet

comment:2 Changed 5 years ago by mark

  • Review set to srl

As it turns out, the problem was caused by a malformed language tag (I think), but not a _ - difference. Added test and better exception.

comment:3 Changed 5 years ago by srl

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:4 Changed 4 years ago by emmons

  • Milestone 24dvet deleted

Milestone 24dvet deleted

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.