[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #6650(closed: fixed)

Opened 5 years ago

Last modified 3 weeks ago

Swedish currency format should use regular decimal symbol (comma)

Reported by: markus Owned by: fredrik
Component: other Data Locale: sv
Phase: Review: pedberg
Weeks: 0.1 Data Xpath:
Xref:

Description (last modified by markus) (diff)

We got feedback from colleagues, including an in-country contact and another i18n-knowledgeable native of Sweden, that the Swedish currency format should use the same decimal symbol (the comma) as non-currency formatting. (That is, we should delete the <currencyDecimal>.)

To paraphrase slightly:

Changing to 123,45 kr is a good recommendation, and supported by Språkrådet (http://www.språkrådet.se/).

1 SEK isn't worth very much, so web sites selling consumer goods (like the http://netonnet.se or http://blocket.se mentioned in ticket:5542) would normally not write out any decimals. People in general would most often write either 123:– or 123,45 kr. (Note also that "kr" is absent when writing :– and that very few people today would write 123:45 kr, and almost no-one would ever write 123,– kr.)

But if you look at any finance site, it quickly becomes obvious that 123,45 kr is the normal format when actually writing out the decimals:

http://www.dn.se/ekonomi/bors/bors-hem/

Attachments

Change History

comment:1 Changed 5 years ago by markus

  • Description modified (diff)

comment:2 Changed 5 years ago by kent.karlsson14@…

I'm not sure where on Språkrådet's site you find any mention of this. I don't find any, not on their site anyway.

But instead see http://www.skiljetecken.se/kolon.php, which does mention this, and recommends colon for this.

It is true that recommendations and use regarding this varies. Especially toady, when it is easy to apply a general number formatter, and use that for all numeric values, whether currency value or not. And many tools don't offer special formatting for currency values. So this leads to many cases where currency values are formatted just like other numeric values. This in turn leading to accepting the "fallback" as a recommendation, usually as an alternative to the preferred use of ":" here.

However, I'd like to be a bit traditional, and use ":" between currency unit value and currency subunit value; in the case of Swedish kronor: kronor and ören. Many currencies have this division between currency unit and currency subunit: dollar&cent, euro&cent, franc&centime, etc.

Most currencies in use today, that at all have a subunit, have a decimal subunit, and of those most use a subunit that is 100th of the main unit. See
http://en.wikipedia.org/wiki/Decimal_currency
http://en.wikipedia.org/wiki/Denomination_(currency)
http://en.wikipedia.org/wiki/Non-decimal_currencies

So, to be nitpicking using ":" it is a division between currency (main) unit value and currency subunit value, whereas using "," one only considers the currency main unit (with decimals), ignoring the currency subunit as such.

Ok, it's a bit moot, both because the currency subunit is just about always decimal (as is indeed the case for Swedish krona) and also (for the Swedish currency itself) because there now are no valid Swedish "öre" coins. Prices (for "cheap" items) are still often with an "öre" part, though, and credit card payments are down to the öre (cash payments cannot, since there are no valid öre coins anymore). But more and more often, the "öre" part is completely left out. (Whether "kr" is written out or not is really orthogonal to this.)

Getting back to the ticket at hand:

If a user of CLDR/ICU wants to use a generic numeric value formatter for a currency value, then it is easy to do so. (Thus ignoring that there is a subunit, or indeed that currency values are in any way at all special.)

If however, the user has gone through the trouble of using a special formatter for currency values, they should get the traditional formatting for them, ":" between the kronor part and the öre part, and indeed also get "." (full stop) as grouping separator, which is the traditional grouping separator for currency values. I still recommend that for all currencies, given that just about all of them have a named decimal subunit. (It would not be perfect for ouguiya and ariary, since those currencies don't have a decimal subunit; one could deal with that by just excepting those two currencies (using comma instead of colon as decimal separator), which can be done in the current CLDR LDML formalism.)

comment:3 Changed 5 years ago by markus

comment:4 Changed 5 years ago by fredrik

Like Kent, I was unable to find support for this change on Språkrådet's website. I also think that the current trend of using a regular decimal point for currency amounts is due to websites not expressly using the currency format, but rather generic numerical formatting. In a way, they are setting a common usage precedent by not implementing CLDR formatting correctly.

That said, "Svenska skrivregler" and TNC's "Skrivregler" say that both forms are acceptable. Like Kent points out above, it depends on if we are to view the separator as a decimal separator (fractional kronors) or a unit separator (kronor:öre). The end result, in cases of currencies divided into 100 sub units like cents or öre, is of course the same.

I would recommend letting this be resolved in survey tool, but also give clear guidance to vetters whether the separator is meant for fractions or units.

comment:5 Changed 5 years ago by mark

This is the sort of question that does not lend itself well to resolution via the survey tool. Instead, we should canvas knowledgeable people and respected references (including major newspapers, etc) to help decide. [If (but *only* if) both forms of usage are equally common, I suspect that it would be simplest to use the same decimal as for regular numbers.]

comment:6 Changed 5 years ago by roubert

For reference, this is what Språkrådet and Terminologicentrum write about this topic.


Språkrådet, "Svenska skrivregler", 3rd ed., 2008:

§11.7 Belopp

Ett belopp som två kronor och femtio öre kan skrivas på flera sätt. Observera att punkt inte ska användas som decimaltecken. I valet mellan komma och kolon som skiljetecken rekommenderas komma.

2 kronor 50 öre
2 kr 50 öre
2,50 kr
2:50 kr
kr 2,50 (vid bokföring)

Motsvarande regler gäller även för andra valutor: 2,50 euro (2,50 €). (Se ▶ 10.8.1 om ordningen mellan belopp och valutakod.)

När ett belopp saknar örestal eller krontal (eller motsvarande i andra valutor) anges detta i vissa sammanhang, t.ex. på prislappar, med tankstreck tillsammans med komma eller kolon. Tankstrecket står då för 0 (noll). Man brukar inte sätta ut valutaslaget, om detta är självklart i sammanhanget.

10,— eller 10:—
—,50 eller —:50
11,— kr eller 11:— kr
11,— €


Terminologicentrum TNC, "Skrivregler för svenska och engelska från TNC (TNC 100)", 2nd printing, 2004:

§179 Penningbelopp

Penningbelopp skrivs i regel med siffror. Sedan länge används i svenskan kolon som skiljetecken mellan kronor och ören. Man kan också följa svensk standard och använda decimalkomma i stället. Punkt får aldrig användas som decimaltecken i svensk text.

149:50 kr eller 149,50 kr

Penningbelopp indelas precis som andra stora tal i tresiffriga grupper från slutet räknat. På värdehandlingar och motsvarande kan man skilja grupperna åt med punkter, t.ex. 2.352.123 kr, för att försvåra senare ändringar av beloppet. (Av samma skäl skriver man ibland ihop beloppet med namnet eller beteckningen på valutan.) I alla andra sammanhang används för penningbelopp liksom för andra tal mellanrum i stället för punkt, jämför punkt 177.


comment:7 Changed 5 years ago by roubert

  • Cc roubert added

comment:8 Changed 5 years ago by emmons

  • Owner changed from anybody to fredrik
  • Status changed from new to assigned
  • Milestone changed from UNSCH to 25dsub

comment:9 Changed 5 years ago by emmons

  • Milestone changed from 25dsub to 25rc

Moving all 25dsub and 25design tickets to 25rc. If you plan to complete items in the 25M1 time frame, please move those tickets to 25M1.

comment:10 Changed 5 years ago by emmons

  • Priority changed from assess to medium
  • Milestone changed from 25rc to 25M1

comment:11 Changed 5 years ago by fredrik

After review, Apple does not object to harmonizing this and use the decimal separator. I will remove the currency separator from Swedish data.

comment:12 Changed 5 years ago by kent.karlsson14@…

I strongly object to "harmonising" the currency "decimal" separator and the general numbers decimal separator; I likewise object to using space as the currency value grouping separator. The text (in Swedish) quoted above supports having colon and full stop as currency decimal separator and grouping separator, not the other way around. Using colon and full stop for this is quite common, although not ubiquitous, in bills and other documents dealing with currency values. For those who really want to use the general numbers decimal and grouping separators also for currency values, that is easy enough already. Why make it harder to use the, quite common, special decimal and grouping separators for currency values?

comment:13 Changed 5 years ago by pedberg

  • Keywords Apple15610945 added

The <currencyDecimal> with colon for Swedish was added in CLDR 22 and the first ICU version including it was ICU 50.

The first Mac OS X version with colon as default currencyDecimal for Swedish was OS X 10.9 (with ICU 51), and since its release, Apple has been getting bug reports from Swedish users who object to having colon as default decimal separator, and reports about problems in accounting apps caused by this change.

Whatever may be preferable in some abstract sense or per government docs, having colon as the currencyDecimal does not seem to be what many or most Swedish users expect or want.

comment:14 Changed 5 years ago by fredrik

  • Review set to pedberg

comment:15 Changed 5 years ago by pedberg

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:16 Changed 5 years ago by emmons

  • Milestone 25M1 deleted

Milestone 25M1 deleted

comment:17 Changed 3 weeks ago by mark

  • Component changed from main to other
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.