[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #6775(closed defect: duplicate)

Opened 5 years ago

Last modified 4 years ago

Feedback for Number Format Tester SpelloutRules for Polish

Reported by: daniel.wojciechowski@… Owned by: grhoten
Component: main Data Locale: pl
Phase: Review:
Weeks: Data Xpath:
Xref:

ticket:6774

ticket:5879

Description

pl

1000	jeden tysiąc   SHOUD BE: tysiąc
2000	dwa tysiące    OK
3000	trzy tysiące   OK
4000	cztery tysiące OK
5000	pięć tysięcy   OK
21000	dwadzieścia jeden tysięcy  OK
22000	dwadzieścia dwa tysięcy    SHOULD BE: dwadzieścia dwa tysiące
23000	dwadzieścia trzy tysięcy   SHOULD BE: dwadzieścia trzy tysiące
24000	dwadzieścia cztery tysięcy SHOULD BE: dwadzieścia cztery tysiące
25000	dwadzieścia pięć tysięcy   OK

ru

1000	одна тысяча    SHOULD BE: тысяча
2000	две тысячи     OK
3000	три тысячи     OK
4000	четыре тысячи  OK
5000	пять тысяч     OK
21000	двадцать одна тысяч   SHOULD BE: двадцать одна тысяча
22000	двадцать две тысяч    SHOULD BE: двадцать две тысячи
23000	двадцать три тысяч    SHOULD BE: двадцать три тысячи
24000	двадцать четыре тысяч SHOULD BE: двадцать четыре тысячи
25000	двадцать пять тысяч   OK

Attachments

Change History

comment:1 Changed 5 years ago by emmons

  • Owner changed from anybody to grhoten
  • Priority changed from assess to medium
  • Status changed from new to assigned
  • Component changed from survey to data
  • Milestone changed from UNSCH to 25rc

comment:2 Changed 5 years ago by grhoten

  • Data Locale changed from ru pl to pl
  • Xref set to 6774
  • Summary changed from Feedback for Number Format Tester SpelloutRules to Feedback for Number Format Tester SpelloutRules for Polish

Ticket 6774 will be used to track Russian. This one will be used to track Polish.

comment:3 Changed 5 years ago by kent.karlsson14@…

Regarding "jeden tysiąc" vs. just "tysiąc" (and similar for many locales): That is more a question of level of formality. In most cases I (when originally submitting RBNF data for some seventy locales) opted for formality (including the "one" before "hundred" and "thousand"). And I think the cases that are still informal, they should be made formal, as that is both clearer and more correct. Thus moving towards formality and away from informality here, and not the other way around.

Regarding the inflections in various Slavic languages (tysiąc/tysiące/tysięcy and similar): For now the inflection is covered only for 1-20 as multiplier (to "thousand", "million", etc.). The repeat part (a hundred repeats for each of "thousand", "million", etc.) isn't. If you can find a concise and actually working solution expressed in the RBNF language (and preferably with the current implementation of the RBNF language), please submit it. I have so far been unsuccessful.

comment:4 Changed 4 years ago by grhoten

  • Status changed from assigned to closed
  • Xref changed from 6774 to 6774 5879
  • Resolution set to duplicate

The remaining Polish issue is a duplicate of ticket:5879

comment:5 Changed 4 years ago by emmons

  • Milestone 25rc deleted

Milestone 25rc deleted

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.