[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #6786(closed unknown: duplicate)

Opened 4 years ago

Last modified 4 years ago

Consistent use of "-" vs "_" across data set in CLDR

Reported by: rxaviers@… Owned by: anybody
Component: unknown Data Locale:
Phase: Review:
Weeks: Data Xpath:
Xref:

Description

Throughout the same JSON data set, both "en-GB", and "en_GB" are used interchangeably as shown below.

Main data:
{

"main": {

"en-GB": { <=================

"identity": {

"version": {

"_cldrVersion": "24",
"_number": "$Revision: 9280 $"

},
"generation": {

"_date": "$Date: 2013-08-27 13:07:13 -0500 (Tue, 27 Aug 2013) $"

},
"language": "en",
"territory": "001"

}

}

}

}

Supplemental data:
{

"supplemental": {

"version": {

"_cldrVersion": "24",
"_number": "$Revision: 9270 $"

},
"generation": {

"_date": "$Date: 2013-08-25 16:44:03 -0500 (Sun, 25 Aug 2013) $"

},
"parentLocales": {

"parentLocale": {

"en_GB": "en_001" <=================

}

}

}

}

According to the documentation http://www.unicode.org/reports/tr35/#Unicode_language_identifier, both "en-GB", and "en_GB" are all Unicode language identifiers. Because, sep = "-" | "_". So, they are both valid and there's nothing wrong with ti. Although, if they were at least consistent across the same data set (all sep = "-", or all sep = "_"), it would make application's implementation easier.

Is there a chance this could be considered? Having "-", or "_" consistently used across the same JSON data set (perhaps could be an optional parameter of the json tool)?

Thanks!

Mark Davis replied:

Any particular data set in CLDR, including the JSON data, should be consistent about use of "-" vs "_".

Attachments

Change History

comment:1 Changed 4 years ago by emmons

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of CldrBug:6780

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.