[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #6973(closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Incorrect Windows Time Zone Mapping

Reported by: mj1856@… Owned by: yoshito
Component: supplemental Data Locale:
Phase: Review: emmons
Weeks: Data Xpath:
Xref:

Description

Asia/Nicosia is currently mapped to E. Europe Standard Time in the Windows time zone mappings.

While the transition dates are aligned, the times are not.

This should probably be mapped to GTB Standard Time, which is used by Greece, and has the same dates but with the correct times.

Attachments

Change History

comment:1 follow-up: ↓ 4 Changed 4 years ago by mj1856@…

Of course, that begs the question of what is E. Europe Standard Time supposed to be used for? As far as I can tell, it doesn't currently align with anything at all.

comment:2 Changed 4 years ago by emmons

  • Owner changed from anybody to yoshito
  • Status changed from new to assigned
  • Milestone changed from UNSCH to 25rc

comment:3 in reply to: ↑ description Changed 4 years ago by yoshito

Replying to mj1856@…:

Asia/Nicosia is currently mapped to E. Europe Standard Time in the Windows time zone mappings.

While the transition dates are aligned, the times are not.


I confirmed this.

This should probably be mapped to GTB Standard Time, which is used by Greece, and has the same dates but with the correct times.


I agree. There are currently zones matching the rule for year 2013 - 2014

  • FLE Standard Time - (UTC+02:00) Helsinki, Kyiv, Riga, Sofia, Tallinn, Vilnius
  • GTB Standard Time - (UTC+02:00) Athens, Bucharest
  • Turkey Standard Time - (UTC+02:00) Istanbul


Among above, GTB (stands for Greece / Turkey / Belarus ? - although Turkey/Belarus are now included in different Windows zones) Standard Time looks better than others because FLE covers northern/eastern Europe regions using East European Time, while GTB covers southern Europe, and Turkey Standard Time is too specific.

I'll update the mapping data for CLDR 25. Thanks for your report.

comment:4 in reply to: ↑ 1 Changed 4 years ago by yoshito

Replying to mj1856@…:

Of course, that begs the question of what is E. Europe Standard Time supposed to be used for? As far as I can tell, it doesn't currently align with anything at all.


Right. Historically, "E. Europe Standard Time" was matching some eastern European regions, such as Kaliningrad and Minsk, but these zones shifted one hour ahead a while ago. Since then, the Windows zone "E. Europe Standard Tiem" is no longer matching any where in the world according to the tz database.

comment:5 Changed 4 years ago by yoshito

  • Priority changed from assess to medium
  • Review set to emmons

comment:6 Changed 4 years ago by yoshito

  • Status changed from assigned to reviewing

comment:7 Changed 4 years ago by emmons

  • Status changed from reviewing to closed
  • Resolution set to fixed

comment:8 Changed 4 years ago by emmons

  • Milestone 25rc deleted

Milestone 25rc deleted

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.