[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #6979(closed enhancement: fixed)

Opened 4 years ago

Last modified 4 years ago

Number system for Chinese lunar calendar days

Reported by: pedberg Owned by: pedberg
Component: main Data Locale:
Phase: Review: emmons
Weeks: Data Xpath:
Xref:

ticket:5023

Description

For zh and zh_Hant, the preferred day numbering uses a number system not currently supported in CLDR, as shown below (along with the results for the supported hanidec and hans/hant numbering systems). We need to support this and then specify it for Chinese calendar days. Perhaps we can name it "hanidays" or something similar.

day	  desired
num	  day num   hanidec   hans/hant
01	    初一      一         一
02	    初二      二         二
03	    初三      三         三
04	    初四      四         四
05	    初五      五         五
06	    初六      六         六
07	    初七      七         七
08	    初八      八         八
09	    初九      九         九
10	    初十      一〇       十
11	    十一      一一       十一
12	    十二      一二       十二
13	    十三      一三       十三
14	    十四      一四       十四
15	    十五      一五       十五
16	    十六      一六       十六
17	    十七      一七       十七
18	    十八      一八       十八
19	    十九      一九       十九
20	    二十      二〇       二十
21	    廿一      二一       二十一
22	    廿二      二二       二十二
23	    廿三      二三       二十三
24	    廿四      二四       二十四
25	    廿五      二五       二十五
26	    廿六      二六       二十六
27	    廿七      二七       二十七
28	    廿八      二八       二十八
29	    廿九      二九       二十九
30	    三十      三〇       三十
(after 30 does not matter,
can fall back to hans/hant)

Attachments

Change History

comment:1 Changed 4 years ago by pedberg

  • Xref set to 5023

This request is also in cldrbug 5023:

comment:2 Changed 4 years ago by deborah

  • Cc deborah added

comment:3 Changed 4 years ago by kent.karlsson14@…

I'd suggest the RBNF part of this extends the "idea" to up to 49, since there are Han characters for 30 (丗) and 40 (𠦜) that are cognate to the character used for 20 (廿). As always for "public" (i.e. non-private) rulesets, negatives, zero and fractions are here covered in the rules (even though that also will not be used for month days). Note that these rules will not use the characters 廿, 丗, 𠦜 for parts of larger numbers (like 124), in order to keep the size of these rulesets down. The 丗 character does not have the kOtherNumeric property with value 30, but I think that is a mistake in the Unihan database.

%spellout-numbering-days:

-x: 負>>;
x.x: =#,###0.#=;
0: 初=%spellout-numbering=;
11: =%spellout-numbering=;
21: =%%numbering-days=;

%%numbering-days:

0: =%spellout-numbering=;
21: 廿>>;
30: <<十;
31: 丗>>;
40: <<十;
41: 𠦜>>;
50: =%spellout-numbering=;

comment:4 Changed 4 years ago by kent.karlsson14@…

PS: The %spellout-numbering ruleset of one of the zh locales is used in the rulesets in the above comment.

comment:5 Changed 4 years ago by emmons

  • Owner changed from anybody to pedberg
  • Status changed from new to assigned
  • Milestone changed from UNSCH to 25rc

comment:6 Changed 4 years ago by pedberg

Approved in TC 2014-Feb-12. Check whether this numbering system is used for anything other than days.

comment:7 Changed 4 years ago by pedberg

OK, I have found an example of this numbering also being used in Japanese for days and years in Japanese calendar dates, in which case it needs to go past 30: "平成廿三年十月丗一日" (here it is being used for year 23, day 31).

Last edited 4 years ago by pedberg (previous) (diff)

comment:8 Changed 4 years ago by pedberg

Note that for 30, Japanese uses 丗 U+4E17, while Chinese tends to use 卅 U+5345, but since Chinese does not use the 30 character for day numbering we pick 丗 U+4E17 here.

Forty should instead be U+534C 卌 which is far more common than U+2099C 𠦜. Again, this would only possibly be relevant for years in Japanese calendar dates.

Last edited 4 years ago by pedberg (previous) (diff)

comment:9 Changed 4 years ago by pedberg

  • Status changed from assigned to reviewing
  • Review set to emmons
  • Added hanidays number system (special for 1-49, above that uses hans)
  • Changed zh[_Hant] chinese-calendar standard date patterns to use it (with this traditional day numbering we drop the day marker '日')

I did a trial integration of this change into icu4c (not committed), then ran tests of the hanidays number system and zh chinese-calendar date formatting against it, and they all seemed to behave as intended.

Last edited 4 years ago by pedberg (previous) (diff)

comment:10 Changed 4 years ago by emmons

  • Status changed from reviewing to closed
  • Resolution set to fixed

comment:11 Changed 4 years ago by emmons

  • Milestone 25rc deleted

Milestone 25rc deleted

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.