[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #7431(closed: duplicate)

Opened 5 years ago

Last modified 4 years ago

Move CLDRFile data on distinguishing elements to XML

Reported by: skeet@… Owned by: mark
Component: other-supplemental Data Locale:
Phase: dsub Review:
Weeks: Data Xpath: //supplementalData/metadata/distinguishing
Xref:

ticket:7434

Description (last modified by mark) (diff)

was: yeartype should be a distinguishing attribute

Move CLDRFile data on distinguishing elements to XML, and load from that data in CLDRFile. Depends on removing the dependency in supplementalDataInfo on CLDRFile (separate bug)

====

Currently yeartype is not listed in any distinguishingItems element, and thus is not a distinguishing attribute. However, where yeartype is used, it is effectively part of the key. For example, within //ldml/dates/calendars/calendar[@type='hebrew']/months/monthContext[@type='format']/monthWidth[@type='wide'] in root.xml, we have:

<month type="7">Adar</month>
<month type="7" yeartype="leap">Adar II</month>

The yeartype has to be a distinguishing attribute for these two elements not to have the same path.

Attachments

Change History

comment:1 Changed 5 years ago by mark

"yearType" is already a distinguishing element, in the internal tooling.

The problem is that the internal tooling (in CLDRFile.java) is more complete than the supplementalMetadata.xml file, which only has a very small subset of the real items.

Jon, I suggest that you file a bug to move the data for the distinguishing elements from CLDRFile to supplementalMetadata.xml.

comment:2 Changed 5 years ago by emmons

  • Owner changed from anybody to mark
  • Priority changed from assess to medium
  • Status changed from new to assigned
  • Milestone changed from UNSCH to 26rc

comment:3 Changed 4 years ago by mark

  • Milestone changed from 26rc to 27dsub

comment:4 Changed 4 years ago by markus

  • Phase set to dsub
  • Milestone changed from 27dsub to 27

comment:5 Changed 4 years ago by mark

  • Summary changed from yeartype should be a distinguishing attribute to Move CLDRFile data on distinguishing elements to XML
  • Description modified (diff)
  • Milestone changed from 27 to 28

comment:6 Changed 4 years ago by mark

  • Status changed from assigned to closed
  • Xref set to 7434
  • Resolution set to duplicate
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.