[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #7528(closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Confusing "Superfluous Plural Form" messages for some compact decimal forms

Reported by: pedberg Owned by: emmons
Component: survey Data Locale:
Phase: dvet Review: pedberg
Weeks: Data Xpath:
Xref:

Description

In the Survey Tool for many languages (e.g. French, Spanish), hovering over the winning entry for 5-digits-long-one and 6-digits-long-one produces the message "Superfluous Plural Form", see e.g. http://st.unicode.org/cldr-apps/v#/fr/Compact_Decimal_Formatting/1f6746c27bede353

ExampleGenerator produces this message if PluralSamples does not have examples for the combination of numeric value and plural form - and it does not have samples for values > 9999 (haven't looked at why this message does not appear for cases other than the above).

Attachments

Change History

comment:1 Changed 4 years ago by mark

The problem is that we should actually be suppressing those forms. That is, the form

00 thousand

can never occur, since it will only be used with two digit items (10..99), and those can never be singular (for French or English). It is a bit more complicated, since we have to ensure that none of the infinite fractional values with two digits can be singular,

10.1 .. 10.9, 10.01 .. 10.99, .. 11.1 ..

I am assigned an open bug to actually suppress these in ST, but have had the time to do it. So the most we have right now is the 'warning'.

comment:2 Changed 4 years ago by emmons

  • Owner changed from anybody to emmons
  • Status changed from new to assigned

TC agreed to drop the message "Superfluous plural form".

comment:3 Changed 4 years ago by emmons

  • Priority changed from assess to minor
  • Milestone changed from UNSCH to 26dvet

comment:4 Changed 4 years ago by emmons

  • Status changed from assigned to reviewing
  • Review set to pedberg

Peter, please mark the STI spreadsheet as well.

comment:5 Changed 4 years ago by pedberg

  • Status changed from reviewing to closed
  • Resolution set to fixed

comment:6 Changed 4 years ago by markus

  • Phase set to dvet
  • Milestone changed from 26dvet to 26
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.