[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #7714(closed enhancement: fixed)

Opened 4 years ago

Last modified 3 years ago

Add Coverage check for vetting

Reported by: mark Owned by: emmons
Component: xxx-test Data Locale:
Phase: rc Review: mark
Weeks: Data Xpath:
Xref:

Description

Our goal is full modern coverage, so any path for the CLDR org locales with modern coverage that doesn't have a confirmed item should cause an error.

Attachments

Change History

comment:1 Changed 4 years ago by emmons

  • Status changed from new to assigned
  • Component changed from unknown to test
  • Priority changed from assess to medium
  • Milestone changed from UNSCH to 27dvet
  • Owner changed from anybody to emmons
  • Type changed from unknown to enhancement

comment:2 Changed 4 years ago by markus

  • Phase set to dvet
  • Milestone changed from 27dvet to 27

comment:3 Changed 3 years ago by emmons

  • Status changed from assigned to reviewing
  • Review set to mark

comment:4 Changed 3 years ago by mark

  • Status changed from reviewing to accepted

The change for

.setCause(this).setMainType(CheckStatus.errorType).setSubtype(Subtype.missingPluralInfo)
to
.setCause(this).setMainType(CheckStatus.warningType).setSubtype(Subtype.missingPluralInfo)

I think should be fixed, to use the errorType for VETTING and RESOLUTION, but not final.

comment:5 Changed 3 years ago by emmons

  • Phase changed from dvet to rc

comment:6 Changed 3 years ago by emmons

  • Status changed from accepted to reviewing

The problem here is that there isn't a clear 1-1 correspondence between the CheckCLDR phases, and the survey tool phases, and that probably needs to be looked at. In the ST main code we have:

    public enum Phase {
        SUBMIT("Data Submission", CheckCLDR.Phase.SUBMISSION), // SUBMISSION
        VETTING("Vetting", CheckCLDR.Phase.VETTING), VETTING_CLOSED("Vetting Closed", CheckCLDR.Phase.FINAL_TESTING), // closed
        // after
        // vetting
        // -
        // open
        // for
        // admin
        CLOSED("Closed", CheckCLDR.Phase.FINAL_TESTING), // closed
        DISPUTED("Dispute Resolution", CheckCLDR.Phase.VETTING), FINAL_TESTING("Final Testing", CheckCLDR.Phase.FINAL_TESTING), // FINAL_TESTING
        READONLY("Read-Only", CheckCLDR.Phase.FINAL_TESTING), BETA("Beta", CheckCLDR.Phase.SUBMISSION);

We usually use SUBMIT, VETTING, VETTING_CLOSED and READONLY in the configuration.
So VETTING_CLOSED is using CheckCLDR.Phase.FINAL_TESTING where it maybe should be using CheckCLDR.Phase.VETTING instead, however this creates a host of different problems.
I just opened Cldrbug:8196 to track that issue.

So for this test, I think it is as good as it can be right now, because there are only 4 CheckCLDR.Phases - SUBMISSION, VETTING, FINAL_TESTING, and BUILD.

comment:7 Changed 3 years ago by mark

  • Status changed from reviewing to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.