[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #7910(closed: fixed)

Opened 4 years ago

Last modified 4 years ago

Deprecated data showing up in CLDR

Reported by: mark Owned by: mark
Component: other-supplemental Data Locale:
Phase: final Review: emmons
Weeks: Data Xpath:
Xref:

Description (last modified by mark) (diff)

From one of my item counting programs (filed ticket:7909 to add regular unit test).

Error: attribute «visibility» is deprecated in ldml, collation? but occurs in live data.

Here is the problem. It doesn't explicitly occur in the data, but the DTD has:

<!ATTLIST collation visibility ( internal | external ) "external" > <!-- deprecated -->

So the problem is that the DTD inserts it; IF you are using a validating parser. Of course, we've discovered over time that we should not have used these default parameters, but that's water under the bridge.


I realized that we could solve the immediate problem by changing the DTD to only exclude the 'internal' value:

<deprecatedItems elements="collation" attributes="visibility"/>

=>

<deprecatedItems elements="collation" attributes="visibility" values="internal"/>

Attachments

Change History

comment:1 Changed 4 years ago by mark

  • Description modified (diff)

comment:2 Changed 4 years ago by mark

  • Status changed from new to reviewing
  • Component changed from unknown to data-supplemental
  • Priority changed from assess to critical
  • Milestone changed from UNSCH to 26
  • Owner changed from anybody to mark
  • Review set to emmons

More details: the problem is backward compatibility.

Currently, you can use the cldr tools (or XPath, or, anything similar to it) to access CLDR XML data:

  1. take the path "ldml/collations/collation[@type="standard"][@visibility="external"]/cr"
  2. Look it up in af.xml.
  3. You get "&N<<<ʼn" as the value.

That *only* works because of the default value. If you simply change to #IMPLICIT, you get null, so it fails.

We haven't even verified that all CLDR tools would work with the change, and we can't verify that others (using XPath, etc.) would.

That's why I want to just make the change that works—without compatibility problems—for this release. Longer term, we should look at a more thorough fix. It is just that I think that is a more delicate process than we want to do right right before a release.

See http://unicode.org/cldr/trac/ticket/7911

comment:3 Changed 4 years ago by emmons

  • Status changed from reviewing to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.