[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #8003(closed: fixed)

Opened 4 years ago

Last modified 4 years ago

Nateni 'ntm' exemplar set has {ɔ̰} twice but {ɔ̰̀} missing

Reported by: moyogo@… Owned by: emmons
Component: data-other Data Locale: ntm
Phase: final Review: mark
Weeks: Data Xpath:
Xref:

ticket:8259

Description

The current character exemplar is
[a {à} {á} {a̰} {à̰} {á̰} b c d e {è} {é} ɛ {ɛ̀} {ɛ́} {ɛ̰} {ɛ̰̀} {ɛ̰́} f h i {ì} {í} {ḭ} {ḭ̀} {ḭ́} k {kp} m n {ǹ} {ń} o {ò} {ó} ɔ {ɔ̀} {ɔ́} {ɔ̰} {ɔ̰} {ɔ̰́} p s t u {ù} {ú} {ṵ} {ṵ̀} {ṵ́} w y]

The Nateni orthography uses the tilde below to indicate nasalization, the acute for high tone and the grave for low tone.
The vowels that can be nasalized are a ɛ i ɔ u. As expected they can all be found with the acute and the grave, except for ɔ which has {ɔ̰̀} missing but {ɔ̰} twice instead.

This seems to be a error, the second {ɔ̰} should be {ɔ̰̀}.

Attachments

Nateni-ntm-exemplar.patch (1.2 KB) - added by moyogo@… 4 years ago.
replace {ɔ̰} {ɔ̰} {ɔ̰́} with {ɔ̰} {ɔ̰̀} {ɔ̰́}

Change History

Changed 4 years ago by moyogo@…

replace {ɔ̰} {ɔ̰} {ɔ̰́} with {ɔ̰} {ɔ̰̀} {ɔ̰́}

comment:1 Changed 4 years ago by emmons

  • Owner changed from anybody to emmons
  • Priority changed from assess to medium
  • Status changed from new to assigned
  • Milestone changed from UNSCH to 27

comment:2 Changed 4 years ago by emmons

John to run CLDRModify vs. examplar sets to clean up and reformat things.

comment:3 Changed 4 years ago by emmons

  • Status changed from assigned to reviewing
  • Component changed from unknown to data-other
  • Review set to mark

comment:4 Changed 4 years ago by mark

  • Cc Lorna_Evans@… added
  • Status changed from reviewing to accepted

Am returning this review. When I looked at the detailed changes, one issue popped out because of the normalization.

Should also run this by Lorna.

In the languages that originally listed the quotation mark, that character is removed—since it is a punctuation mark!
U+2019 ( ’ ) RIGHT SINGLE QUOTATION MARK
such as http://unicode.org/cldr/trac/changeset/11072/trunk/exemplars/main/aak_Latn.xml

Other languages are marked as using modifier letter:
U+02BC ( ʼ ) MODIFIER LETTER APOSTROPHE
such as http://unicode.org/cldr/trac/changeset/11072/trunk/exemplars/main/apd_Latn.xml

Or the U+A78C ( ꞌ ) LATIN SMALL LETTER SALTILLO (~18 locales)
such as http://unicode.org/cldr/trac/changeset/11072/trunk/exemplars/main/aom_Latn.xml

  1. I strongly suspect that the languages marked as using the quotation mark are in error, that they should be changed to be the MODIFIER LETTER APOSTROPHE. That will cause it to be preserved in the exemplar characters
  2. I'm also suspicious that at least some of the languages using the SALTILLO should also use the MODIFIER LETTER APOSTROPHE instead.
  3. Also, in http://unicode.org/cldr/trac/changeset/11072/trunk/exemplars/main/kmu_Latn.xml we see:

<exemplarCharacters draft="unconfirmed">[a e f h i k l m {mp} n {nt} o p s t u v y ꞌ {ꞌk} {ꞌm} {ꞌn} {ꞌv} {ꞌy}]</exemplarCharacters>

  1. It is normally superfluous to list both ꞌ freestanding, and in combination with others. The only special case would be if the combination has very different behavior (just like we might have [c h {ch}] if the collation order is different). Thus normally:
  2. If it only occurs before k, m, n, v, y, then the freestanding version should be removed.
  3. If it occurs in arbitrary combination, then the specific versions {ꞌk} {ꞌm} {ꞌn} {ꞌv} {ꞌy} should be removed
  1. The same happens with trunk/exemplars/main/avu_Latn.xml and others for MODIFIER LETTER APOSTROPHE
  2. http://unicode.org/cldr/trac/changeset/11072/trunk/exemplars/main/lmp_Latn.xml has the modifier letter in the exemplars and the U+A78B ( Ꞌ ) LATIN CAPITAL LETTER SALTILLO in the index. One or the other is surely wrong.

comment:5 Changed 4 years ago by emmons

  • Phase changed from dsub to final

comment:6 Changed 4 years ago by emmons

Ugh - it's going to be a pain, but you're right, we're going to have to look into this. Since it's in exemplars only, I'm moving it to "final" instead of "dsub"...

comment:7 Changed 4 years ago by emmons

  • Status changed from accepted to reviewing
  • Xref set to 8259

Filed CLdrbug:8259 for follow up on the items in comment 4.

comment:8 Changed 4 years ago by mark

  • Status changed from reviewing to closed
  • Resolution set to fixed
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.