[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #8420(closed: duplicate)

Opened 4 years ago

Last modified 4 years ago

Even more on ; number list separator

Reported by: srl Owned by: pedberg
Component: numbers Data Locale:
Phase: dvet Review:
Weeks: Data Xpath:
Xref:

ticket:4661

ticket:5963

ticket:8314

Description

I was trying to remember what <list>;</list> was for. ticket:5963 took some steps, but some more documentation (at least) would help on this element:

  • document that <list/> is NOT "list patterns"
  • document that <list/> is for "localized formatting of the subpattern character". I don't think "separates lists of numbers" will help users.
  • remove all values not in root
  • consider deprecation.

Attachments

Change History

comment:1 Changed 4 years ago by mark

  • Owner changed from anybody to kristi
  • Priority changed from assess to medium
  • Status changed from new to accepted
  • Component changed from other to numbers
  • Milestone changed from UNSCH to 28

Kristi is going to find out how it is used in MS products so that we can document it.

We won't deprecate or remove it.

comment:2 Changed 4 years ago by pedberg

  • Cc srl, mark, pedberg added
  • Phase changed from dsub to dvet
  • Xref changed from 5963 to 4661 5963

Another related old bug is cldrbug 4661: with a related document: https://docs.google.com/document/d/1utyqGBb1ctqqLJL--C7euc049ASo4wwZtPOGL2mHXSo/edit

Old versions of Excel for Mac (from the 1990s) used to get a similar value from old Mac OS locale data: It was called "listSep" and defined as the "character that separates numbers, as when a list of numbers is entered by the user". We have had a long-standing request to provide an equivalent from CLDR/ICU data.

I believe that was the intent of the CLDR data. However on the ICU side that got conflated with the character used to separate number patterns, and though in ICU the data key is still symbols/list, the constants used to refer to it are (e.g.) DecimalFormatSymbols::kPatternSeparatorSymbol and - for use with unum_getSymbol - UNUM_PATTERN_SEPARATOR_SYMBOL.

In the document referenced above I suggest that change DecimalFormatSymbols::kPatternSeparatorSymbol / UNUM_PATTERN_SEPARATOR_SYMBOL to always return a semicolon without reference to CLDR data, and then define new constants to get the symbols/list value.

comment:3 Changed 4 years ago by kristi

  • Owner changed from kristi to pedberg
  • Status changed from accepted to design

This looks to be dupe of 8314, assigning to peter to confirm and resolve as a dupe.

comment:4 Changed 4 years ago by pedberg

  • Status changed from design to closed
  • Xref changed from 4661 5963 to 4661 5963 8314
  • Resolution set to duplicate

Yes, copied the relevant info to 8314, resolving this as a dupe.

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.