[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #8455(closed: as-designed)

Opened 4 years ago

Last modified 5 months ago

Persian decimal separator

Reported by: pedberg Owned by: anybody
Component: other Data Locale: fa
Phase: dsub Review:
Weeks: Data Xpath:
Xref:

Description

We have received a report that Persian decimal separator should be

  • U+002F SOLIDUS

instead of the current

  • U+066B ARABIC DECIMAL SEPARATOR

I am filing this ticket for investigation...

Attachments

Change History

comment:1 Changed 4 years ago by shervin

My sources (including ISIRI 6219 and ISIRI 9147) are explicitly mentioning that use of Solidus in place of "ممیز" (decimal separator) is not correct. Using Solidus is implying division and fraction. This character is placed on Shift+E02 while Solidus is on

This is 3.14:

۳٫۱۴

This is 3⁄14 (=3÷14):

۳/۱۴

The source of this confusion is because U+066B should be rendered as glyph vaguely half the size of Solidus and with smaller or equal right angle.

Last edited 4 years ago by shervin (previous) (diff)

comment:2 Changed 4 years ago by roozbeh

What Shervin said. Basically slash is not the character to use. It also creates some bidi issues we need to avoid.

The original report is probably due to a font not optimized for Persian. The range of acceptable Persian glyphs for the decimal separator is smaller than that of Arabic. See Noto Naskh Arabic for a good shape.

comment:3 Changed 4 years ago by pedberg

Thanks for the feedback! I will wait until the committee has a look, but we can probably resolve this as invalid or as-designed.

comment:4 Changed 4 years ago by emmons

  • Status changed from new to closed
  • Resolution set to as-designed

comment:5 Changed 4 years ago by pedberg

Seems like the issue is really about correct display in the font, not about the character used.

comment:6 Changed 5 months ago by mark

  • Component changed from main to other
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.