[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #8498(closed: as-designed)

Opened 4 years ago

Last modified 4 years ago

Time zone abbreviations should apply at root language

Reported by: mj1856@… Owned by: anybody
Component: timezone Data Locale:
Phase: dsub Review:
Weeks: Data Xpath:
Xref:

Description

From common/main/en.xml:

  <zone type="Europe/London">
    <long>
      <daylight>British Summer Time</daylight>
    </long>
  </zone>
  <zone type="Europe/Dublin">
    <long>
      <daylight>Irish Standard Time</daylight>
    </long>
  </zone>

From common/main/en_GB.xml:

  <zone type="Europe/London">
    <short>
      <daylight>BST</daylight>
    </short>
  </zone>

From common/main/en_IE.xml:

  <zone type="Europe/Dublin">
    <short>
      <daylight>IST</daylight>
    </short>
  </zone>

When accessing from other English locales, such as en_US, I only get the long names and not the short ones? That doesn't seem right. The short names should probably be moved to the en.xml file.

I would expect:

  <zone type="Europe/London">
    <long>
      <daylight>British Summer Time</daylight>
    </long>
    <short>
      <daylight>BST</daylight>
    </short>
  </zone>
  <zone type="Europe/Dublin">
    <long>
      <daylight>Irish Standard Time</daylight>
    </long>
   <short>
      <daylight>IST</daylight>
    </short>
  </zone>

There may be other cases like this in other languages as well.

Attachments

Change History

comment:1 Changed 4 years ago by mark

  • Status changed from new to closed
  • Resolution set to as-designed

By design, we only expose the abbreviations in places where we think they'll be generally understood.

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.