[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #8535(closed: fixed)

Opened 4 years ago

Last modified 3 years ago

Survey tool Loading error (Date & time)

Reported by: kristi Owned by: emmons
Component: surveytool-other Data Locale:
Phase: dvet Review: pedberg
Weeks: Data Xpath:
Xref:

Description

Go to any locale (confirmed with Korean, German, and Italian)
Go to Date & Time

Load error (see attached screenshot)

Attachments

CLDR load error.JPG (35.3 KB) - added by kristi 4 years ago.
inheritance markers.png (20.0 KB) - added by pikse@… 4 years ago.

Change History

Changed 4 years ago by kristi

comment:1 Changed 4 years ago by emmons

  • Status changed from new to accepted
  • Priority changed from assess to critical
  • Phase changed from dsub to dvet
  • Milestone changed from UNSCH to 28
  • Owner changed from anybody to emmons
  • type changed from unknown to survey

comment:2 Changed 4 years ago by pikse@…

I get this too on Estonian locale when trying to access specific sections or when trying to vote on dashboard for items that are included in the same sections.

More specifcally it says:
Exception while loading: section - voteForItem.votes[surveyUser.id] is undefined, n=TypeError

I had access to these sections a week ago or so. Seems the error occurs since apple/google user voted or imported its old votes. If logging out and then viewing these specific sections I notice these specific sections (weather, speed, volume and duaration units) have in common that each has an item where 1) I haven't voted yet, 2) there's voting tie between google and apple and 3) one of the translations that apple/google voted for shows up as inherited (blue background). I don't know if this is relevant, but other unit sections which I can access if logged in doesn't have such items.

comment:3 Changed 4 years ago by emmons

Thanks for the additional info. Had a unsuccessful debugging session last night. Perhaps this will help me figure it out.

Changed 4 years ago by pikse@…

comment:4 Changed 4 years ago by pikse@…

For items where clicking "Fix" gives this error the winning value on dashboard now shows up as ↑↑↑ (see inheritance_markers.png).

Seems to relate to how voting for an inherited item is handled. Another odd thing which I encounter related to inherited items is that if I vote for an inherited "Tahiti" here then it shows up that I voted for a separate losing translation while the non-inherited winning translation is exactly the same "Tahiti". And the inherited item that I voted for still shows up as if it was inherited. I'm pretty sure that voting for an inherited was lately equal to adding the same value as a new translation which doesn't show up inherited. Not sure why this inherited "Tahiti" is currently shown at all if it's the same as non-inherited winning translation.

comment:5 Changed 4 years ago by emmons

  • Status changed from accepted to reviewing
  • Review set to pedberg

comment:6 Changed 3 years ago by pedberg

  • Status changed from reviewing to closed
  • Resolution set to fixed
  • Component changed from unknown to survey
View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.