[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #9964(closed data: fixed)

Opened 8 months ago

Last modified 4 months ago

Move Norther Kurdish (ku/ku_latn/kmr) out of seed? Actually just update basic data

Reported by: federicoleva@… Owned by: emmons
Component: main Data Locale:
Phase: dsub Review: pedberg
Weeks: Data Xpath:
Xref:

Description

#9748, #9460, #9913 contain data that we need added to CLDR for the MediaWiki locale "ku"/"ku-latn". I just added a trusted vetter for ku who is ready to translate all language names etc.

I understand that to add data we first of all need to move ku out of seed. Seeing http://www.unicode.org/repos/cldr/trunk/seed/main/ku.xml , I'll specify below what data is ok and what needs to be added or changed, following the format of http://cldr.unicode.org/index/cldr-spec/minimaldata/form . Then I'll ask our Kurdish translator to correct any mistake.

  1. Administrative / Locale Identifier

0.a) Requester's Name and Email address: Federico Leva and Ghybu

0.b) Locale name: Kurdish (Northern Kurdish/Kurmancî)

0.c) Locale identifier(s):

ku, ku_Latn, ku_TR, kmr

  1. Exemplar Sets

1.a) Main:

as is [see example: https://ku.wikipedia.org/wiki/W%C3%AEk%C3%AEpediya )

1.b) Auxiliary:

<exemplarCharacters type="auxiliary">[á à ă â å ä ã ā æ é è ĕ ë ē í ì ĭ ï ī ñ ó ò ŏ ô ø ō œ ß ú ù ŭ ū ÿ]</exemplarCharacters>

1.c) Index:

as is

1.d) Punctuation:

<exemplarCharacters type="punctuation">[\- ‐ – — , ; \: ! ? . … ' ‘ ’ " “ ” ( ) \[ \] § @ * / \& # † ‡ ′ ″]</exemplarCharacters>

  1. Orientation

2.a) Characters: LTR

2.b) Lines: top-to-bottom

  1. Plural Rules

3.a) What are the plural rules for this language?

Same group as "tr" and "ckb".

  1. Country Data and Default Content

4.a) Is the data in http://www.unicode.org/cldr/charts/latest/supplemental/language_territory_information.html correct for the language and territory?

Yes.

4.b) What should the default content locale be for the language?

ku_TR / ku_Latn

  1. Romanization: –

Attachments

Change History

comment:1 Changed 4 months ago by emmons

  • Owner changed from anybody to emmons
  • Status changed from new to accepted
  • Milestone changed from UNSCH to 32

comment:2 Changed 4 months ago by emmons

I think that perhaps you misunderstand. CLDR data can be added and voted on via the survey tool regardless of whether it is in "seed" or "common". The determination of when a locale moves from "seed" to "common" is done at the end of a release when we evaluate the amount of data received in any given seed locale vs. the Miminal Data Commitment as outlined in http://cldr.unicode.org/index/cldr-spec/minimaldata#TOC-Minimal-Data-Commitment

Right now, that determination is a manual and subjective one done by the TC members. We would like to automate that process, as outlined in http://unicode.org/cldr/trac/ticket/8230.

However, no one has had time to work on that up until now.

My best recommendations for you:

1). Make sure you and/or your vetter have a survey tool account, and are prepared to submit data via the survey tool during the data submission phase scheduled to open in early May.
See http://cldr.unicode.org/index/survey-tool/accounts

2). Use the ST to contribute data. If you are the only ones providing data for Northern Kurdish and have a "guest" account, sometimes we will allow your vetter to have regular vetter instead of "guest" status, which makes it easier to get confirmed data. We deal with these on a case by case basis during the submission process.

3). At the end of the release, if the locale has sufficient data, then it will be moved from seed to main per CLDR TC decision.

I will go ahead and use this ticket to update any of the seed data that we currently have, which will insure that the ST is correct when we start data submission.

comment:3 Changed 4 months ago by emmons

I should also note that we have some data for "ku", but it is all draft="unconfirmed". I will check with the major CLDR contributors to see if they are planning to have vetters on board for "ku" in this release cycle. See point #2 in my comment above.

comment:4 Changed 4 months ago by emmons

  • Priority changed from assess to minor
  • Status changed from accepted to reviewing
  • Review set to pedberg

comment:5 Changed 4 months ago by pedberg

  • Status changed from reviewing to closed
  • Resolution set to fixed
  • Summary changed from Move Norther Kurdish (ku/ku_latn/kmr) out of seed to Move Norther Kurdish (ku/ku_latn/kmr) out of seed? Actually just update basic data

comment:6 Changed 4 months ago by jefgen

  • Cc kristil, jefgen added

comment:7 Changed 4 months ago by federicoleva@…

Ok. I asked to move the locale out of seed because AFAICS some other data (which can't be entered via the survey tool) was rejected in other tickets due to the locale being in seed. Please check those tickets again to integrate any data which is still missing.

I think I provided all the required data to move the locale out of seed. As for the survey tool, we should be all set for the next round with our vetter.

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.