[Unicode]   Common Locale Data Repository : Bug Tracking Home | Site Map | Search
 
Modify

CLDR Ticket #10858(closed data: as-designed)

Opened 9 months ago

Last modified 8 months ago

Incorrect plural rule in Latvian (lv) for cardinal numbers ending in 11..19

Reported by: flodolo@… Owned by: mark
Component: plurals Data Locale:
Phase: dsub Review:
Weeks: Data Xpath:
Xref:

Description

Issue was reported as part of Mozilla localization (while I work on Mozilla l10n, I'm not a native speaker of Latvian).

According to CLDR
http://www.unicode.org/cldr/charts/dev/supplemental/language_plural_rules.html#lv

'zero': n % 10 = 0 or n % 100 = 11..19
'one': n % 10 = 1 and n % 100 != 11
'other': any other number

According to our localizer, cardinal numbers from 11 to 19 should use the 'other' form, resulting in a different 'zero' rule

'zero': n % 10 = 0
'one': n % 10 = 1 and n % 100 != 11
'other': any other number

Bug reference: https://bugzilla.mozilla.org/show_bug.cgi?id=1415896

Attachments

Change History

comment:1 Changed 9 months ago by mark

  • Owner changed from anybody to mark
  • Priority changed from assess to major
  • Type changed from unknown to data
  • Status changed from new to accepted
  • Milestone changed from UNSCH to 33

comment:2 follow-up: ↓ 3 Changed 8 months ago by mark

I looked over the bug reference to https://bugzilla.mozilla.org/show_bug.cgi?id=1415896.

We need more verification. What helps for these is to look over the table on http://www.unicode.org/cldr/charts/latest/supplemental/language_plural_rules.html#lv and use that information to verify that the change is an improvement. That is, that a Latvian user would never say the current values:

11 diennakšu
...
19 diennakšu

and would always say instead the proposed values:

11 diennaktis
...
19 diennakšu

comment:3 in reply to: ↑ 2 Changed 8 months ago by mark

Replying to mark:

I looked over the bug reference to https://bugzilla.mozilla.org/show_bug.cgi?id=1415896.

We need more verification. What helps for these is to look over the table on http://www.unicode.org/cldr/charts/latest/supplemental/language_plural_rules.html#lv and use that information to verify that the change is an improvement. That is, that a Latvian user would never say the current values:

11 diennakšu
...
19 diennakšu

and would always say instead the proposed values:

11 diennaktis
...
19 diennaktis

comment:4 Changed 8 months ago by chiara

Update from Google linguist: both forms are possible in Latvian.
11 diennakšu - undeclinable numeral (10-20) + noun in Plural Gen.
11 diennaktis - undeclinable numeral (10-20) + noun in Plural Nom.

Preferable would be diennakšu - noun in plural Gen. (in line with current charts http://www.unicode.org/cldr/charts/latest/supplemental/language_plural_rules.html#lv )
I asked to provide link to at least 2-3 resources, to be added to the ticket as soon as shared.

comment:5 Changed 8 months ago by chiara

Additional details available here: http://www.languagesandnumbers.com/how-to-count-in-latvian/en/lav/ (noun comes in gen.)

comment:6 Changed 8 months ago by mark

  • Status changed from accepted to closed
  • Resolution set to as-designed
  • Milestone changed from 33 to UNSCH

Ok, I'm closing this as "as-designed", and UNSCH (..eduled).

comment:7 Changed 8 months ago by flodolo@…

To close the feedback circle: while he agrees that the form for 11..19 could use both nominative and genitive in Latvian, he also confirmed that he would use nominative for 11-19

11 diennaktis
...
19 diennaktis

Will file a new bug (or ask to reopen this?) in case we can find documentation to support the request change, since so far we only have support for the genitive form.

View

Add a comment

Modify Ticket

Action
as closed
Next status will be 'new'
Next status will be 'closed'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.